mendeleydesktop and libpulse

After a recent update to mendeleydesktop 1.8, I got some annoying error messages:

$ mendeleydesktop 
Using bundled Qt version 4.6 because no system Qt version was found
Running /opt/mendeleydesktop/bin/..//lib/mendeleydesktop/libexec/mendeleydesktop.i486 
/opt/mendeleydesktop/bin/..//lib/mendeleydesktop/libexec/mendeleydesktop.i486: error while loading shared libraries: libpulse.so.0: cannot open shared object file: No such file or directory

If you see this error, you most likely have not installed pulseaudio. I'm not quite sure why viewing PDF annotations requires pulseaudio, but nevertheless, you should refrain from installing everything from pulseaudio if you do not plan to actually use it. Here is how to restrict the USE-flags to a reasonable set

# echo 'media-sound/pulseaudio -X -alsa -asyncns -caps -dbus -gdbm glib -gtk -ipv6 -orc -ssl -tcpd -udev -webrtc-aec' >> /etc/portage/package.use
# emerge -av media-sound/pulseaudio

But that would have been too easy. Unfortunately, Qt is not forward compatible (surprise!). Currently, I have version 1.8.2 on my machine, but this version does not go well with the build from mendeley. You can fix this by prepend LD_LIBRARY_PATH (or make an alias for that).

$ mendeleydesktop 
Using bundled Qt version 4.6 because no system Qt version was found
Running /opt/mendeleydesktop/bin/..//lib/mendeleydesktop/libexec/mendeleydesktop.i486 
/opt/mendeleydesktop/bin/..//lib/mendeleydesktop/libexec/mendeleydesktop.i486: error while loading shared libraries: libpulse.so.0: cannot open shared object file: No such file or directory
$ LD_LIBRARY_PATH="/opt/mendeleydesktop/lib/" /opt/mendeleydesktop/bin/..//lib/mendeleydesktop/libexec/mendeleydesktop.i486

You may also like...

Leave a Reply

Your email address will not be published.