dist upgrade: immediate configuration

During the dist upgrade from debian squeeze to wheezy, I got the following error from apt-get.

E: Could not perform immediate configuration on 'gcj-4.7-jre'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

The manual suggests to disable this method for dist upgrades. Googling suggests using

apt-get dist-upgrade -o APT::Immediate-Configure=false

Although this looks suitable to solve the problem, I get the very same error message again. Fooling around with the command line leads to the resolution:

apt-get install gcj-4.7-jre

Afterwards, apt-get dist-upgrade continues without showing the error once again.

You may also like...

Leave a Reply

Your email address will not be published.